Vulnonym.org

CVE-2008-2307 - Sapropelic Man

Description

Unspecified vulnerability in WebKit in Apple Safari before 3.1.2 as distributed in Mac OS X before 10.5.4 and standalone for Windows and Mac OS X 10.4 allows remote attackers to cause a denial of service (application crash) or execute arbitrary code via vectors involving JavaScript arrays that trigger memory corruption.

Reference

http://lists.apple.com/archives/security-announce/2008//Jun/msg00001.html http://www.securityfocus.com/bid/29836 https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00319.html https://www.redhat.com/archives/fedora-package-announce/2008-July/msg00279.html http://lists.apple.com/archives/security-announce/2008//Jul/msg00001.html http://secunia.com/advisories/30801 http://support.apple.com/kb/HT2165 http://support.apple.com/kb/HT2163 http://lists.apple.com/archives/security-announce/2008//Jun/msg00003.html http://www.kb.cert.org/vuls/id/361043 http://secunia.com/advisories/30775 http://secunia.com/advisories/31074 http://support.apple.com/kb/HT2092 http://secunia.com/advisories/30992 http://www.securitytracker.com/id?1020330 http://www.vupen.com/english/advisories/2008/1882/references http://www.vupen.com/english/advisories/2008/1981/references http://www.vupen.com/english/advisories/2008/1980 http://www.vupen.com/english/advisories/2008/2094/references