Vulnonym.org

CVE-2008-2665 - Hard hit Slav

Description

Directory traversal vulnerability in the posix_access function in PHP 5.2.6 and earlier allows remote attackers to bypass safe_mode restrictions via a .. (dot dot) in an http URL which results in the URL being canonicalized to a local filename after the safe_mode check has successfully run.

Reference

http://securityreason.com/achievement_securityalert/54 http://www.securityfocus.com/bid/29797 http://www.securitytracker.com/id?1020327 http://securityreason.com/securityalert/3941 http://wiki.rpath.com/Advisories:rPSA-2009-0035 http://lists.apple.com/archives/security-announce/2009/May/msg00002.html http://secunia.com/advisories/35074 http://www.vupen.com/english/advisories/2009/1297 http://www.us-cert.gov/cas/techalerts/TA09-133A.html http://support.apple.com/kb/HT3549 http://marc.info/?l=bugtraq&m=124654546101607&w=2 http://secunia.com/advisories/35650 http://marc.info/?l=bugtraq&m=125631037611762&w=2 http://secunia.com/advisories/32746 http://security.gentoo.org/glsa/glsa-200811-05.xml https://exchange.xforce.ibmcloud.com/vulnerabilities/43196 http://www.securityfocus.com/archive/1/501376/100/0/threaded