Vulnonym.org

CVE-2008-2545 - Mural Junior

Description

Skype 3.6.0.248 and other versions before 3.8.0.139 uses a case-sensitive comparison when checking for dangerous extensions which allows user-assisted remote attackers to bypass warning dialogs and possibly execute arbitrary code via a file: URI with a dangerous extension that uses a different case.

Reference

http://labs.idefense.com/intelligence/vulnerabilities/display.php?id=711 http://www.skype.com/security/skype-sb-2008-003.html http://www.securityfocus.com/bid/29553 http://www.securitytracker.com/id?1020201 http://secunia.com/advisories/30547 http://www.vupen.com/english/advisories/2008/1749/references https://exchange.xforce.ibmcloud.com/vulnerabilities/43044