Vulnonym.org

CVE-2008-2426 - Heterodont Cabinet

Description

Multiple stack-based buffer overflows in Imlib 2 (aka imlib2) 1.4.0 allow user-assisted remote attackers to cause a denial of service (crash) or possibly execute arbitrary code via (1) a PNM image with a crafted header related to the load function in src/modules/loaders/loader_pnm.c; or (2) a crafted XPM image related to the load function in src/modules/loader_xpm.c.

Reference

http://secunia.com/secunia_research/2008-25/advisory/ http://www.securityfocus.com/bid/29417 http://securitytracker.com/id?1020146 http://secunia.com/advisories/30401 https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00030.html https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00052.html https://www.redhat.com/archives/fedora-package-announce/2008-June/msg00113.html http://secunia.com/advisories/30485 http://www.gentoo.org/security/en/glsa/glsa-200806-03.xml http://www.debian.org/security/2008/dsa-1594 http://secunia.com/advisories/30572 http://secunia.com/advisories/30727 http://www.mandriva.com/security/advisories?name=MDVSA-2008:123 http://lists.opensuse.org/opensuse-security-announce/2008-09/msg00004.html http://www.ubuntu.com/usn/USN-697-1 http://secunia.com/advisories/31982 http://www.vupen.com/english/advisories/2008/1700 https://exchange.xforce.ibmcloud.com/vulnerabilities/42732 http://www.securityfocus.com/archive/1/492739/100/0/threaded