Vulnonym.org

CVE-2008-2149 - Fabricated Queer

Description

Stack-based buffer overflow in the searchwn function in Wordnet 2.0 2.1 and 3.0 might allow context-dependent attackers to execute arbitrary code via a long command line option. NOTE: this issue probably does not cross privilege boundaries except in cases in which Wordnet is used as a back end.

Reference

https://bugs.gentoo.org/show_bug.cgi?id=211491 http://www.securityfocus.com/bid/29208 http://secunia.com/advisories/30242 http://www.debian.org/security/2008/dsa-1634 http://www.mandriva.com/security/advisories?name=MDVSA-2008:182 http://secunia.com/advisories/31654 http://secunia.com/advisories/32184 http://www.gentoo.org/security/en/glsa/glsa-200810-01.xml http://www.vupen.com/english/advisories/2008/1527/references https://exchange.xforce.ibmcloud.com/vulnerabilities/42378