Vulnonym.org

CVE-2008-2146 - Remunerative Thickness

Description

wp-includes/vars.php in Wordpress before 2.2.3 does not properly extract the current path from the PATH_INFO ($PHP_SELF) which allows remote attackers to bypass intended access restrictions for certain pages.

Reference

http://trac.wordpress.org/changeset/6029 http://trac.wordpress.org/changeset?old_path=tags%2F2.2.2&old=6063&new_path=tags%2F2.2.3&new=6063#file10 http://trac.wordpress.org/ticket/4748 http://osvdb.org/45188 https://exchange.xforce.ibmcloud.com/vulnerabilities/42379