Vulnonym.org

CVE-2008-2042 - Theophanic Translators

Description

The Javascript API in Adobe Acrobat Professional 7.0.9 and possibly 8.1.1 exposes a dangerous method which allows remote attackers to execute arbitrary commands or trigger a buffer overflow via a crafted PDF file that invokes app.checkForUpdate with a malicious callback function.

Reference

http://www.adobe.com/support/security/bulletins/apsb08-13.html http://securitytracker.com/id?1019971 http://sunsolve.sun.com/search/document.do?assetkey=1-26-239286-1 http://secunia.com/advisories/30840 http://securityreason.com/securityalert/3861 http://www.vupen.com/english/advisories/2008/1966/references https://exchange.xforce.ibmcloud.com/vulnerabilities/42237 http://www.securityfocus.com/archive/1/491735/100/0/threaded