Vulnonym.org

CVE-2008-2044 - Gymnorhinal Poll

Description

includes/library.php in netOffice Dwins 1.3 p2 compares the demoSession variable to the ‘true’ string literal instead of the true boolean literal which allows remote attackers to bypass authentication and execute arbitrary code by setting this variable to 1 as demonstrated by uploading a PHP script via an add action to projects_site/uploadfile.php.

Reference

http://www.securityfocus.com/archive/1/488958 http://sourceforge.net/forum/forum.php?forum_id=814851 http://www.securityfocus.com/bid/28051 http://securityreason.com/securityalert/3845 http://netofficedwins.sourceforge.net/modules/news/article.php?storyid=47 http://secunia.com/advisories/29193 http://www.securityfocus.com/archive/1/491542/100/0/threaded