Vulnonym.org

CVE-2008-1878 - Rugulose Parachute

Description

Stack-based buffer overflow in the demux_nsf_send_chunk function in src/demuxers/demux_nsf.c in xine-lib 1.1.12 and earlier allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long NSF title.

Reference

http://secunia.com/advisories/29850 http://www.securityfocus.com/bid/28816 https://www.redhat.com/archives/fedora-package-announce/2008-April/msg00536.html https://www.redhat.com/archives/fedora-package-announce/2008-April/msg00571.html http://secunia.com/advisories/30021 http://lists.opensuse.org/opensuse-security-announce/2008-06/msg00001.html http://www.mandriva.com/security/advisories?name=MDVSA-2008:177 http://secunia.com/advisories/31372 http://www.mandriva.com/security/advisories?name=MDVSA-2008:178 http://secunia.com/advisories/30581 http://secunia.com/advisories/31393 http://www.ubuntu.com/usn/usn-635-1 http://security.gentoo.org/glsa/glsa-200808-01.xml http://www.debian.org/security/2008/dsa-1586 http://secunia.com/advisories/30337 http://www.vupen.com/english/advisories/2008/1247/references https://exchange.xforce.ibmcloud.com/vulnerabilities/41865 https://www.exploit-db.com/exploits/5458