Vulnonym.org

CVE-2007-6019 - Agamid Barf

Description

Adobe Flash Player 9.0.115.0 and earlier and 8.0.39.0 and earlier allows remote attackers to execute arbitrary code via an SWF file with a modified DeclareFunction2 Actionscript tag which prevents an object from being instantiated properly.

Reference

http://www.zerodayinitiative.com/advisories/ZDI-08-021 http://www.adobe.com/support/security/bulletins/apsb08-11.html http://www.redhat.com/support/errata/RHSA-2008-0221.html http://www.securityfocus.com/bid/28694 http://www.securitytracker.com/id?1019810 http://www.us-cert.gov/cas/techalerts/TA08-100A.html http://securityreason.com/securityalert/3805 http://lists.opensuse.org/opensuse-security-announce/2008-04/msg00006.html http://secunia.com/advisories/29763 http://www.gentoo.org/security/en/glsa/glsa-200804-21.xml http://secunia.com/advisories/29865 http://lists.apple.com/archives/security-announce/2008//May/msg00001.html http://sunsolve.sun.com/search/document.do?assetkey=1-26-238305-1 http://www.us-cert.gov/cas/techalerts/TA08-150A.html http://secunia.com/advisories/30430 http://secunia.com/advisories/30507 http://www.vupen.com/english/advisories/2008/1697 http://www.vupen.com/english/advisories/2008/1724/references https://exchange.xforce.ibmcloud.com/vulnerabilities/41717 https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A10160 http://www.securityfocus.com/archive/1/490824/100/0/threaded http://www.securityfocus.com/archive/1/490623/100/0/threaded