Vulnonym.org

CVE-2008-0884 - Coaly Exhibits

Description

The Replace function in the capp-lspp-config script in the (1) lspp-eal4-config-ibm and (2) capp-lspp-eal4-config-hp packages before 0.65-2 in Red Hat Enterprise Linux (RHEL) 5 uses lstat instead of stat to determine the /etc/pam.d/system-auth file permissions leading to a change to world-writable permissions for the /etc/pam.d/system-auth-ac file which allows local users to gain privileges by modifying this file.

Reference

https://bugzilla.redhat.com/show_bug.cgi?id=435442 http://rhn.redhat.com/errata/RHSA-2008-0193.html http://www.securityfocus.com/bid/28557 http://securitytracker.com/id?1019740 http://secunia.com/advisories/29642 https://exchange.xforce.ibmcloud.com/vulnerabilities/41584