Vulnonym.org

CVE-2008-1612 - Computational Knees

Description

The arrayShrink function (lib/Array.c) in Squid 2.6.STABLE17 allows attackers to cause a denial of service (process exit) via unknown vectors that cause an array to shrink to 0 entries which triggers an assert error. NOTE: this issue is due to an incorrect fix for CVE-2007-6239.

Reference

http://www.squid-cache.org/Versions/v2/2.6/changesets/11882.patch http://www.squid-cache.org/Advisories/SQUID-2007_2.txt http://www.openwall.com/lists/oss-security/2008/04/01/5 http://marc.info/?l=squid-announce&m=120614453813157&w=2 http://www.ubuntu.com/usn/usn-601-1 http://www.securityfocus.com/bid/28693 http://www.redhat.com/support/errata/RHSA-2008-0214.html http://secunia.com/advisories/29813 http://secunia.com/advisories/27477 https://www.redhat.com/archives/fedora-package-announce/2008-April/msg00560.html http://lists.opensuse.org/opensuse-security-announce/2008-05/msg00000.html http://secunia.com/advisories/30032 http://www.mandriva.com/security/advisories?name=MDVSA-2008:134 http://secunia.com/advisories/32109 http://security.gentoo.org/glsa/glsa-200903-38.xml http://secunia.com/advisories/34467 http://www.debian.org/security/2008/dsa-1646 https://exchange.xforce.ibmcloud.com/vulnerabilities/41586 https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11376