Vulnonym.org

CVE-2004-1388 - Incommunicado Joke

Description

Format string vulnerability in the gpsd_report function for BerliOS GPD daemon (gpsd formerly pygps) 1.9.0 through 2.7 allows remote attackers to execute arbitrary code via certain GPS requests containing format string specifiers that are not properly handled in syslog calls.

Reference

http://www.digitalmunition.com/DMA%5B2005-0125a%5D.txt http://lists.berlios.de/pipermail/gpsd-announce/2005-January/000018.html http://www.mail-archive.com/debian-bugs-closed@lists.debian.org/msg02103.html http://marc.info/?l=bugtraq&m=110677341711505&w=2 https://exchange.xforce.ibmcloud.com/vulnerabilities/19079